Thunderbird

From Indie IT Wiki
Jump to: navigation, search

Contents

Thunderbird Releases

https://www.mozilla.org/en-US/thunderbird/all/

curl --silent --head https://www.mozilla.org/en-US/thunderbird/notes/ |grep 'Location:'

Internal Wiki Pages

Thunderbird Add-ons

Thunderbird about:config Modifications

Thunderbird Ubuntu Install

HOWTO: BACKUP:

Profile

http://www.windows-commandline.com/copy-directory-command-line/

Xcopy /E /I C:\dir1\sourcedir D:\data\destinationdir

http://kb.mozillazine.org/Profile_backup

http://mozbackup.jasnapaka.com/command-line-backup.php

If you are not confident enough to manually search for the profile folder there are a couple of add-ons that can do the job for you:

Both of the above add-ons require you to install them and manually add the required buttons to your Mail Toolbar. Once added just click on the button and the default file manager will open at the profile folder.

Address Book

  • Click on the Address Book icon
  • In the open address book window in the left hand column click on the address book you wish to back up
  • Tools >> Export >> Save in the appropriate format

Message Filters

The filtering rules are stored in a file called msgFilterRules.dat within the Thunderbird profile folder, if you have multiple accounts there is a separate file for each account. The file(s) just needs to be backup up and then restored to a profile, on starting Thunderbird it will read and integrate the filters.

Message Tags

The Tags used to mark messages are save within the prefs.js file found in each mail accounts profile. Each Tag has two entries, one for the tag name the other for its colour.

Example 1:

user_pref("mailnews.tags.printed.color", "#3366FF");
user_pref("mailnews.tags.printed.tag", "Printed");

Example 2:

user_pref("mailnews.tags.invoiced.color", "#993300");
user_pref("mailnews.tags.invoiced.ordinal", "00005");
user_pref("mailnews.tags.invoiced.tag", "Invoiced");

Example 2 shows an additional line between 'color' and 'tag', this is because the add-on Tag Sequencer Arranger has been installed.

Ensuring Thunderbird is closed open the prefs.js file with a text editor and search for the following line:

user_pref("mailnews.tags.printed.color",

Copy and paste all the entries in to a separate text file, save and exit both files. The copied entries can be used to overwrite the tag entries in another prefs.js file.

Subject Manager (Add-on)

When you save a subject heading with this add-on it is stored in Thunderbird's prefs.js file.

Ensuring Thunderbird is closed open the prefs.js file with a text editor and search for the following line:

user_pref("extensions.SubjectManager.

There should be six entries the first five being your preference settings and any saved subjects, the sixth is the version number. Copy and paste these in to a separate text file, save and exit both files. The copied entries can be used to overwrite the blank Subject Manager entries in another prefs.js file assuming they are the same version.

NOTE: If they are not the same versions it would be prudent to only copy the saved subjects line and manually change the add-on's settings.

HOWTO: DISABLE:

Firefox Stealing Focus When Opening Browser Links From Any Email Client

NOTE: This fix requires alteration of Firefox's about:config settings not Thunderbird's.

If Firefox is your default browser then when you click on an URL in Thunderbird it is opened and Firefox springs to the foreground.

Config name: browser.tabs.loadDivertedInBackground
Default: False
Modified: True

IMAP Synchronisation (V.3 >)

In v3 > IMAP accounts created or imported are set to automatically synchronise email with the server, if you have a large amount of emails and you use roaming profiles this can greatly impact on log on/off times.

Importing/Recreating An Old IMAP Profile:

If importing an old IMAP profile copy it to the local drive and then unplug the network cable or temporarily disable the network card. If recreating an existing account just unplug the network cable or temporarily disable the network card.

Import the old profile, then:

Linux: Edit >> Account Settings >> Synchronisation & Storage Windows: Tools >> Account Settings >> Synchronisation & Storage

Under 'Message Synchronising' untick 'Keep messages for this account on this computer'

Safe Mode: How To

Windows:

Run thunderbird -safe-mode

Setting Up A New IMAP Account

Linux: Edit >> Account Settings >> Synchronisation & Storage Windows: Tools >> Account Settings >> Synchronisation & Storage

Under 'Message Synchronising' untick 'Keep messages for this account on this computer'

NOTE: Synchronising is done on an account by account basis.

If you are setting up a fresh account untick the box while creating your settings.

Tabs

If you do not wish to read your messages in a tab but in a new window you can disable the feature:

  • Windows >> Tools >> Options >> Advanced >> Reading & Display >> Open messages in: >> An existing message window.
  • Linux >> Edit >> Preferences >> Advanced >> Reading & Display >> Open messages in: >> An existing message window.

This however leaves an open tab which displays the name of the folder you have selected. If you wish to disable this tab you can do so in the Config Editor.

  • Windows >> Tools >> Options >> Advanced >> General >> Config Editor
  • Linux >> Edit >> Preferences >> Advanced >> General >> Config Editor
mail.tabs.autoHide

Change from false to true by double clicking on the entry.

Thanks to Ghacks.

HOWTO: ENABLE:

Archiving Of IMAP Emails To Local Folders

Some internet hosting companies set a limit on the total size of messages and also the total number of messages in your IMAP mailbox account.

With 1&1 (SCHLUND) the total size of messages is 2GB and the total number of messages is 40,000.

To stop from going over this limit of number of messages, you can use Mozilla Thunderbird's Archive feature.

Account Settings > Copies & Folders > Message Archives
Keep message archives in: > Archive options > A single folder + Keep existing folder structure > OK
"Archives" Folder on: > Local Folders > OK

Now, choose a message in one of your IMAP folders, and then click the Archive button.

Then, scroll down to the Local Folders folder and check it has copied the message, whilst recreating the folder structure.

Space, sorted!  :-)

Thanks - https://support.mozilla.org/en-US/kb/archived-messages

Autoreply (Without Sieve)

http://tbirdhowto.wordpress.com/category/auto-reply/

http://tbirdhowto.wordpress.com/2007/02/16/how-to-set-up-an-out-of-office-auto-reply/

Google Calendar Integration

NOTE: From the release of version 38 of Thunderbird Lightning is now pre-installed.

  1. Thunderbird > Tools > Add-ons > Get Add-ons
  2. Search for Lightning and Install.
  3. Search for Provider for Google and Install.
  4. Restart Thunderbird.
  5. Firefox or Chrome > Log into your Google Calendar web interface.
  6. Left hand side > My Calendars > Little down arrow> Settings
  7. Click the blue underline link for one of the Calendars to show the Details page
  8. Find the Private Address: section > Click on XML and copy the URL
  9. Thunderbird > File > New > Calendar
  10. On the Network > Format > Google Calendar > Paste XML URL into Location
  11. Enter your Google username and password, and choose Remember password
  12. Name the calendar the same as in Google, and choose a colour, and click OK.
  13. Thunderbird > Events and Tasks > Calendar

Thanks to Make Use Of

Integration In To Ubuntu Messaging Menu (Linux - Duh)

Terminal:~$

sudo aptitude remove thunderbird-mozilla-build
sudo aptitude install thunderbird-globalmenu thunderbird-locale-en

Filelink (V. 13 >)

Preferences >> Attachments >> Outgoing

Then either sign up for a Box or Hightail account or enter your details for an existing account.

After entering your account details whenever you attach a large file to a new email message a pop-up will appear at the bottom of the compose window (see picture below):

Thunderbird Filelink pop-up.jpg

Click on the 'Link' button and watch the attachment uploading to your chosen online file storage provider (see picture below):

Thunderbird attachement upload.jpg

At the same time there will be a new pop-up at the bottom of the compose window (see picture below):

Thunderbird file being linked.jpg

The message is self-explanatory and if you do not wish to see it again click the 'Never show this again' button.

After the file is uploaded another pop-up at the bottom of the compose window with appear (see picture below):

Thunderbird file upload confirmation.jpg

As well as this pop-up a file link will be inserted in to the body of the message similar to that in the following picture:

Thunderbird file uploaded file link.jpg

Whenever the file is downloaded by a third party you will receive an email conformation.

Vacation / Out Of Office Plugin (Sieve)

NEW VERSION

https://github.com/opensolutions/sieve-out-of-office/pull/2/files?short_path=04c6e90

OLD VERSION

http://adullact.net/plugins/mediawiki/wiki/milimail/index.php/Out_of_Office

    Sieve Settings
      Server Name: 192.168.0.207
             Port: 4190
   Authentication: Use login from IMAP Account
        User Name: test@domain.org.uk
Secure Connection: false

Just create a ~/.procmailrc file in your user's home directory...

DEFAULT=$HOME/.maildir/
LOGFILE=$HOME/procmail.log
DELIVER="/usr/libexec/dovecot/deliver"
DROPPRIVS="YES"
:0 w
| $DELIVER

...and then check the server email logs for the entry...

dovecot: lda(sieve): sieve: msgid=<201307151456.r6FEusZI017531@mail.server.com>: sent vacation response to <me@server.com>

Or, a global /etc/procmailrc for the whole server...

# Use maildir-style mailbox in user's home directory
DEFAULT=$HOME/.maildir/
# Log actions to file
LOGFILE=$HOME/procmail.log
# Log synopsis of messages
LOGABSTRACT=all
# Be verbose
VERBOSE=no
# Pass to Dovecot for Sieve
DELIVER="/usr/libexec/dovecot/deliver"
DROPPRIVS="YES"
:0 w
| $DELIVER

HOWTO: MODIFY:

Custom Dictionary

With Thunderbird closed, navigate to the Profile Folder and locate the file persdict.dat. Open that file with a text editor, edit as needed, then save the file.

Signature Transparency

Alter the 'opacity' value to your liking. Test it here - http://www.w3schools.com/cssref/tryit.asp?filename=trycss3_opacity_js

Create a folder in your profile folder called 'chrome' and then create a file called 'UserContent.css' with the following...

/*
 * Disable TB22 style transparency
 */
.moz-txt-sig, .moz-signature {
  opacity: 0.5 !important;
}

...then restart Thunderbird.

Font Sizes In Panes & Menus

Method 1

http://kb.mozillazine.org/Pane_and_menu_fonts

Method 2

Theme Font & Size Changer

HOWTO: FIX:

Corrupt Downloaded Files Attachments

mail.server.default.fetch_by_chunks => False

Thanks - http://forums.mozillazine.org/viewtopic.php?f=39&t=822995

Restore Calendar

You need to tell Lightning what calendars exists in the local.sqlite file. The corresponding preferences are stored like all preferences in file pref.js in your profile folder and start with "calendar.registry". Restore the lines from the old pref.js file and replace the lines in the new pref.js.

  1. Close Thunderbird if it's running
  2. Copy all files from backup profile directory's calendar-data subdirectory into your new profile directory. Likely local.sqlite is the only file needed, but I had a few others so I copied them over as well.
  3. Open up prefs.js from your backup and look for lines like: user_pref("calendar.list.sortOrder", "3bf851bb-ece1-48df-8de3-c814c05e5fe7");
  4. Open up the same file in your new profile directory and find the same line. If it has a different identifier as its value, replace all occurrences of it with the value from the backup file (there should be 6) and save that file.
  5. Reopen Thunderbird

http://forums.mozillazine.org/viewtopic.php?f=46&t=2461673

http://askubuntu.com/questions/366091/how-to-restore-missing-calendar-data-from-lightning-thunderbird

Error: Segmentaion Fault On NFS Mounted Home Directory With LDAP Auth (Linux)

A mad but simple solution (and no-one out there seems to know why it works)... install the Name Service Caching Daemon package.

Terminal:~$

sudo apt-get install nscd

Now you can start Thunderbird. Yep, bizarre. But who cares? It works.

Error: "Could not initialize the application's security component"

http://mzl.la/1a9lYoa

Open Web Links In Google Browser (Linux)

  • Thunderbird > Edit > Preferences > Attachments > Incoming > http > Use other... > /usr/bin/chromium
  • Thunderbird > Edit > Preferences > Attachments > Incoming > https > Use other... > /usr/bin/chromium
  • Close
  • Restart

Open Web Links In Mozilla Firefox (Linux)

Fix #1

Check your Firefox path:

Terminal:~$ 

which firefox

Thunderbird > Edit > Preferences > Advanced > Config Editor

network.protocol-handler.app.http = /usr/bin/firefox
network.protocol-handler.app.https = /usr/bin/firefox

Fix #2

http://kb.mozillazine.org/Register_protocol

http://gnuru.org/article/1631/changing-browser-in-thunderbird

Fix #3

Later versions of Thunderbird use different config settings:

network.protocol-handler.warn-external.http
network.protocol-handler.warn-external.https

Right click on each entry and select 'Reset'.

http://kb.mozillazine.org/Changing_the_web_browser_invoked_by_Thunderbird

Option To Select Printer Missing

http://ubuntuforums.org/showthread.php?t=205050

Menus Slow To Open

Config name: gfx.direct2d.disabled
Default: false
Modified: true
Config name: layers.acceleration.disabled
Default: false
Modified: true

Thanks to Mozillazine here & here.

Not Printing To Default Printer

http://arstechnica.com/civis/viewtopic.php?f=11&t=224248

Quick Filter Toolbar Closing

The Quick Filter Toolbar closes when you move between different folders. To prevent this happening activate the pin button found on the far left of the toolbar.

Unactivated:

TB Quick Filter Unticked.jpg

Activated:

TB Quick Filter Ticked.jpg

Scanning And Attaching To Email From A Brother All-In-One Printer (Windows)

Brother does not provide built-in support for Thunderbird so this facility has to be provided by a third-party application FileAttach

INFO

Address Book - Launch Standalone Instance

  • Windows 32-bit - Start | Run then enter: "C:\Program Files\Mozilla Thunderbird\thunderbird.exe" -addressbook
  • Windows 64-bit - Start | Run then enter: "C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe" -addressbook
  • Mac OS x - Terminal | cd /Applications/Thunderbird.app/Contents/MacOS | then ./thunderbird-bin -addressbook
  • Linux - Terminal | cd <thunderbird_installation_directory> | then ./thunderbird-bin -addressbook

Thanks to Mozilla.

Online Manual

http://en.flossmanuals.net/thunderbird/

about:config Information

http://kb.mozillazine.org/About:config_entries

Command Line Options

https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options

Compact Folders

Manually:

File --> Compact Folders

Automatically:

Linux: Edit --> Preferences --> Advanced --> Network & Disc Space

Windows: Tools --> Options --> Advanced --> Network & Disc Space

Under the 'Disc Space' section:

  1. Clear the cache and then set it to 50Mb
  2. Change the 'Compact folders when it will save over' to 10Mb

Configuration Files

For the times that you cannot use the about:config editor to manipulate Thunderbird's setting then you can edit the following files:

  • userChrome.css is used to change the appearance of the browser
  • userContent.css is used to change the appearance of web pages
  • user.js is used to change various preferences

All of the above files are in a plain text format so can be edited with any run of the mill text editor.

More here.

Error Console

To open the error console use the keyboard combination 'CTRL+Shift+J'

IMAP - Minimize Profile Size

If you have a IMAP account offline folders are enabled that automatically download copies of the messages in all of your folders. You can disable this feature by unchecking Tools -> Account Settings -> Synchronization & Storage -> "Keep messages for this account on the computer". However, this doesn't delete any existing offline folders. If you have some look at the local directory setting at the bottom of Tools -> Account Settings -> Server Settings to see where Thunderbird stores the files for that account. Exit Thunderbird and delete any files in that directory (and its children) that have the name of a folder but no file extension (mbox files). For example, "inbox." for the inbox folder. Leave the *.msf files alone. The *.sbd files are renamed directories.

Thanks to Mozillazine.

Lightning Versions

https://developer.mozilla.org/en-US/docs/Calendar/Calendar_Versions

Move An Entire Mail Box & It's Messages

http://kb.mozillazine.org/Moving_your_mail_storage_location_%28Thunderbird%29

Remove Unwanted Dictionaries (GENTOO)

http://forums.gentoo.org/viewtopic-t-942972.html

Notification Problem

http://forums.cnet.com/7723-6638_102-515492.html

Links to follow up

https://wiki.archlinux.org/index.php/Thunderbird#Tips_and_tricks

https://cs.uwaterloo.ca/cscf/howto/thunderbird/

http://www.thegeekylinux.com/2014/10/how-to-install-mozilla-thunderbird-in.html